Increased network latency in Sydney
Incident Report for Binary Lane
Resolved
This incident has been resolved.
Posted May 12, 2020 - 19:21 AEST
Investigating
We are currently investigating this issue.
Posted May 12, 2020 - 19:03 AEST